My wallet won't update past 6-2-19

Anyone else have this issue?? What can be done to fix this? It just gets stuck on that date and will not update!!!

What wallet version are you using?

1.4.10. I believe this is the latest version?

No, the latest version is 1.4.18, please download it from here: